Sets the Layout Rule property of rebar set to Maximum Spacing.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public void SetLayoutAsMaximumSpacing( double spacing ) |
Visual Basic |
---|
Public Sub SetLayoutAsMaximumSpacing ( _ spacing As Double _ ) |
Visual C++ |
---|
public: void SetLayoutAsMaximumSpacing( double spacing ) |
Parameters
- spacing
- Type: System..::..Double
The maximum spacing of bars in set.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This RebarFreeFormAccessor doesn't contain a valid rebar reference. -or- This RebarFreeFormAccessor Rebar doesn't contain a valid server GUID. |