Checks if the ElementId is an acceptable conceptual construction type ElementId for the MassLevelData (Mass Floor).
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public bool IsValidConceptualConstructionTypeElement( ElementId id ) |
Visual Basic |
---|
Public Function IsValidConceptualConstructionTypeElement ( _ id As ElementId _ ) As Boolean |
Visual C++ |
---|
public: bool IsValidConceptualConstructionTypeElement( ElementId^ id ) |
Parameters
- id
- Type: Autodesk.Revit.DB..::..ElementId
The ElementId to be checked.
Return Value
True if the ElementId is an acceptable conceptual construction type ElementId, false otherwise.
Remarks
In the case that 'conceptualConstructionIsByEnergyData' is true, invalidElementId is also acceptable input.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |