Exports a selection of views in DWG format.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
Visual Basic |
---|
Public Function Export ( _
folder As String, _
name As String, _
views As ICollection(Of ElementId), _
options As DWGExportOptions _
) As Boolean |
Parameters
- folder
- Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
- name
- Type: System..::..String
Either the name of a single file or a prefix for a set of files.
If empty, automatic naming will be used.
If nullNothingnullptra null reference (Nothing in Visual Basic), throw ArgumentException.
- views
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Selection of views to be exported. The set must contain at least one valid view.
- options
- Type: Autodesk.Revit.DB..::..DWGExportOptions
Various options applicable to the DWG format.
If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
Return Value
True if successful, otherwise False.
Remarks
Examples
CopyC#
public bool ExportDWG(Document document, View view, string setupName)
{
bool exported = false;
IList<string> setupNames = BaseExportOptions.GetPredefinedSetupNames(document);
foreach (string name in setupNames)
{
if (name.CompareTo(setupName) == 0)
{
DWGExportOptions dwgOptions = DWGExportOptions.GetPredefinedOptions(document, name);
ICollection<ElementId> views = new List<ElementId>();
views.Add(view.Id);
exported = document.Export(Path.GetDirectoryName(document.PathName),
Path.GetFileNameWithoutExtension(document.PathName), views, dwgOptions);
break;
}
}
return exported;
}
CopyVB.NET
Public Function ExportDWG(document As Document, view As View, setupName As String) As Boolean
Dim exported As Boolean = False
Dim setupNames As IList(Of String) = BaseExportOptions.GetPredefinedSetupNames(document)
For Each name As String In setupNames
If name.CompareTo(setupName) = 0 Then
Dim dwgOptions As DWGExportOptions = DWGExportOptions.GetPredefinedOptions(document, name)
Dim views As ICollection(Of ElementId) = New List(Of ElementId)()
views.Add(view.Id)
exported = document.Export(Path.GetDirectoryName(document.PathName), Path.GetFileNameWithoutExtension(document.PathName), views, dwgOptions)
Exit For
End If
Next
Return exported
End Function
Exceptions
See Also