Reverses the order in which two elements are joined.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static void SwitchJoinOrder( Document document, Element firstElement, Element secondElement ) |
Visual Basic |
---|
Public Shared Sub SwitchJoinOrder ( _ document As Document, _ firstElement As Element, _ secondElement As Element _ ) |
Visual C++ |
---|
public: static void SwitchJoinOrder( Document^ document, Element^ firstElement, Element^ secondElement ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document containing the two elements.
- firstElement
- Type: Autodesk.Revit.DB..::..Element
The first element.
- secondElement
- Type: Autodesk.Revit.DB..::..Element
The second element. This element must be joined to the first element.
Remarks
The cutting element becomes the cut element and vice versa after the join order is switched.
This functionality is not available for family documents.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document. -or- The elements are not joined. -or- The elements cannot be joined. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Unable to switch the join order of these elements. |