Sets the major layout pattern as FixedNumber, while specifying the needed parameters for this pattern.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2013
Syntax
C# |
---|
public void SetMinorLayoutAsFixedNumber(
double overallLength,
double majorStartOverhang,
double majorEndOverhang,
int numberOfWires
) |
Visual Basic |
---|
Public Sub SetMinorLayoutAsFixedNumber ( _
overallLength As Double, _
majorStartOverhang As Double, _
majorEndOverhang As Double, _
numberOfWires As Integer _
) |
Visual C++ |
---|
public:
void SetMinorLayoutAsFixedNumber(
double overallLength,
double majorStartOverhang,
double majorEndOverhang,
int numberOfWires
) |
Parameters
- overallLength
- Type: System..::..Double
The entire length of the wire sheet in the major direction.
- majorStartOverhang
- Type: System..::..Double
The distance from the edge of the sheet to the first wire in the major direction.
- majorEndOverhang
- Type: System..::..Double
The distance from the last wire to the edge of the sheet in the major direction.
- numberOfWires
- Type: System..::..Int32
The number of the wires to set in the minor direction.
Exceptions
See Also