Set the string value of a family parameter of the current family type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void Set( FamilyParameter familyParameter, string value ) |
Visual Basic |
---|
Public Sub Set ( _ familyParameter As FamilyParameter, _ value As String _ ) |
Visual C++ |
---|
public: void Set( FamilyParameter^ familyParameter, String^ value ) |
Parameters
- familyParameter
- Type: Autodesk.Revit.DB..::..FamilyParameter
A family parameter of the current type.
- value
- Type: System..::..String
The new value for family parameter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input argument-"familyParameter"-is an invalid family parameter. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when the input argument-"familyParameter"-is out of range. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the family parameter is determined by formula, or the current family type is invalid. |