Returns the vectors describing the edge at the specified parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Transform ComputeDerivatives( double parameter ) |
Visual Basic |
---|
Public Function ComputeDerivatives ( _ parameter As Double _ ) As Transform |
Visual C++ |
---|
public: Transform^ ComputeDerivatives( double parameter ) |
Parameters
- parameter
- Type: System..::..Double
The parameter to be evaluated.
Return Value
The transformation containing a tangent vector, derivative of tangent vector, and bi-normal vector.
Remarks
The following is the meaning of the transformation members:
- Origin is the point on the edge (equivalent to Evaluate);
- BasisX is the tangent vector (the first derivative);
- BasisY is the second derivative;
- BasisZ is the bi-normal vector (tangent x normal).