On a curved surface, BeltMeasurement specifies where the
grid's distances are measured.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public double BeltMeasurement { get; set; } |
Visual Basic |
---|
Public Property BeltMeasurement As Double Get Set |
Visual C++ |
---|
public: property double BeltMeasurement { double get (); void set (double value); } |
Remarks
On a conical surface, the distance between the radial gridlines is
not constant. To interpret the Distance property, a circumferential
gridline is taken as the "belt." Distance is then measured along
the belt. The BeltMeasurement property gives the location of the
belt relative to the extremes of the surface. The belt is used
whenever gridlines are not parallel. It defaults to 0.5.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | Thrown when beltMeasurement is outside the range [ 0.0, 1.0 ]. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the gridlines are guaranteed to be parallel; check the HasBeltMeasurement property before using this property. |