Sets start and end point of the line load.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public bool SetPoints( XYZ startPoint, XYZ endPoint ) |
Visual Basic |
---|
Public Function SetPoints ( _ startPoint As XYZ, _ endPoint As XYZ _ ) As Boolean |
Visual C++ |
---|
public: bool SetPoints( XYZ^ startPoint, XYZ^ endPoint ) |
Parameters
- startPoint
- Type: Autodesk.Revit.DB..::..XYZ
The start point.
- endPoint
- Type: Autodesk.Revit.DB..::..XYZ
The end point.
Return Value
Returns true if successful, false otherwise.
Remarks
This method works with non hosted line load only.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the end point is equal to the start point. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |