A revolved face of a 3d solid or open shell.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
Remarks
Revolved faces are defined by a profile curve and a local coordinate system.
For details on the parameterization, refer to the documentation for RevolvedSurface
Examples

private void GetRevolvedFaceInfo(Face face) { RevolvedFace revolvedFace = face as RevolvedFace; if (null != revolvedFace) { XYZ origin = revolvedFace.Origin; XYZ axis = revolvedFace.Axis; Curve curve = revolvedFace.Curve; XYZ redius = revolvedFace.get_Radius(0); } }

Private Sub GetRevolvedFaceInfo(face As Face) Dim revolvedFace As RevolvedFace = TryCast(face, RevolvedFace) If revolvedFace IsNot Nothing Then Dim origin As XYZ = revolvedFace.Origin Dim axis As XYZ = revolvedFace.Axis Dim curve As Curve = revolvedFace.Curve Dim redius As XYZ = revolvedFace.Radius(0) End If End Sub
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Face
Autodesk.Revit.DB..::..RevolvedFace
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB..::..GeometryObject
Autodesk.Revit.DB..::..Face
Autodesk.Revit.DB..::..RevolvedFace