Set colored surface settings object for the style.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public void SetColoredSurfaceSettings( AnalysisDisplayColoredSurfaceSettings coloredSurfaceSettings ) |
Visual Basic |
---|
Public Sub SetColoredSurfaceSettings ( _ coloredSurfaceSettings As AnalysisDisplayColoredSurfaceSettings _ ) |
Visual C++ |
---|
public: void SetColoredSurfaceSettings( AnalysisDisplayColoredSurfaceSettings^ coloredSurfaceSettings ) |
Parameters
- coloredSurfaceSettings
- Type: Autodesk.Revit.DB.Analysis..::..AnalysisDisplayColoredSurfaceSettings
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | colored surface settings were not created with the object. |