Get the size count of the duct size table. The duct shape determines the location of the size in the size table.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public int GetSizeCount( DuctShape shape ) |
Visual Basic |
---|
Public Function GetSizeCount ( _ shape As DuctShape _ ) As Integer |
Visual C++ |
---|
public: int GetSizeCount( DuctShape shape ) |
Parameters
- shape
- Type: Autodesk.Revit.DB.Mechanical..::..DuctShape
The shape of duct.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |