Creates a new parameter definition using specified options.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public Definition Create( ExternalDefinitionCreationOptions option ) |
Visual Basic |
---|
Public Function Create ( _ option As ExternalDefinitionCreationOptions _ ) As Definition |
Visual C++ |
---|
public: Definition^ Create( ExternalDefinitionCreationOptions^ option ) |
Parameters
- option
- Type: Autodesk.Revit.DB..::..ExternalDefinitionCreationOptions
The options used to create the new parameter definition.
Return Value
If successful a reference to the new parameter definition is returned, otherwise nullNothingnullptra null reference (Nothing in Visual Basic).
Remarks
This method only supports creation of new external definitions (shared parameters).