Sets the Layout Rule property of rebar set to NumberWithSpacing
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public void SetLayoutAsNumberWithSpacing( int numberOfBarPositions, double spacing, bool barsOnNormalSide, bool includeFirstBar, bool includeLastBar ) |
Visual Basic |
---|
Public Sub SetLayoutAsNumberWithSpacing ( _ numberOfBarPositions As Integer, _ spacing As Double, _ barsOnNormalSide As Boolean, _ includeFirstBar As Boolean, _ includeLastBar As Boolean _ ) |
Visual C++ |
---|
public: void SetLayoutAsNumberWithSpacing( int numberOfBarPositions, double spacing, bool barsOnNormalSide, bool includeFirstBar, bool includeLastBar ) |
Parameters
- numberOfBarPositions
- Type: System..::..Int32
The number of bar positions in rebar set
- spacing
- Type: System..::..Double
The maximum spacing between rebar in rebar set
- barsOnNormalSide
- Type: System..::..Boolean
Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal
- includeFirstBar
- Type: System..::..Boolean
Identifies if the first bar in rebar set is shown
- includeLastBar
- Type: System..::..Boolean
Identifies if the last bar in rebar set is shown
Remarks
When changing the layout rule to NumberWithSpacing, you must also simultaneously set NumberOfBarPositions,
Spacing, BarsOnNormalSide, IncludeFirstBar, and IncludeLastBar properties.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | the number of bar positions numberOfBarPositions is less than 1 or more than 1002. -or- The spacing isn't bigger than 0.0. |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions..::..InapplicableDataException | This RebarShapeDrivenAccessor is an instance of a spiral or multiplanar shape. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This RebarShapeDrivenAccessor doesn't contain a valid rebar reference. |