Sets the default Divided Surface number for a fixed number layout for U or V gridlines.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public void SetSurfaceNumber( UVGridlineType gridlines, int number ) |
Visual Basic |
---|
Public Sub SetSurfaceNumber ( _ gridlines As UVGridlineType, _ number As Integer _ ) |
Visual C++ |
---|
public: void SetSurfaceNumber( UVGridlineType gridlines, int number ) |
Parameters
- gridlines
- Type: Autodesk.Revit.DB..::..UVGridlineType
U-gridlines or V-gridlines.
- number
- Type: System..::..Int32
A default number for a fixed number layout.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for number is not positive. -or- A value passed for an enumeration argument is not a member of that enumeration |