The current family type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public FamilyType CurrentType { get; set; } |
Visual Basic |
---|
Public Property CurrentType As FamilyType Get Set |
Visual C++ |
---|
public: property FamilyType^ CurrentType { FamilyType^ get (); void set (FamilyType^ value); } |
Remarks
Only the current family type is editable using the methods
in FamilyManager. If you want to modify the properties of
any family type, it must be set to be the current type first.
This value will be nullNothingnullptra null reference (Nothing in Visual Basic) if there is no type in the family. In order
to modify parameter values, you will need to create one using
NewType(String).