Gets the string used in type catalogs to identify a given display unit.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2014
Syntax
C# |
---|
[ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `GetTypeCatalogStringForUnit(ForgeTypeId)` method instead.")]
public static string GetTypeCatalogString(
DisplayUnitType displayUnit
) |
Visual Basic |
---|
<ObsoleteAttribute("This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `GetTypeCatalogStringForUnit(ForgeTypeId)` method instead.")> _
Public Shared Function GetTypeCatalogString ( _
displayUnit As DisplayUnitType _
) As String |
Visual C++ |
---|
[ObsoleteAttribute(L"This method is deprecated in Revit 2021 and may be removed in a future version of Revit. Please use the `GetTypeCatalogStringForUnit(ForgeTypeId)` method instead.")]
public:
static String^ GetTypeCatalogString(
DisplayUnitType displayUnit
) |
Return Value
The type catalog string, or an empty string if the display unit cannot be used in type catalogs.
Exceptions
See Also