Sets Descriptions for all measurements

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2012

Syntax

C#
public void SetMeasurementDescriptions(
	IList<string> measurementDescriptions
)
Visual Basic
Public Sub SetMeasurementDescriptions ( _
	measurementDescriptions As IList(Of String) _
)
Visual C++
public:
void SetMeasurementDescriptions(
	IList<String^>^ measurementDescriptions
)

Parameters

measurementDescriptions
Type: System.Collections.Generic..::..IList<(Of <(<'String>)>)>
Array of measurement descriptions. The lengths of the array must be equal to the number of measurements set during creation of SpatialFieldManager.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException measurementDescriptions lengths is not equal to the number of measurements set during creation of SpatialFieldManager
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also