Creates a new empty stairs element with a default stairs type in the specified levels
and then starts stairs edit mode and editing the new stairs.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public ElementId Start( ElementId baseLevelId, ElementId topLevelId ) |
Visual Basic |
---|
Public Function Start ( _ baseLevelId As ElementId, _ topLevelId As ElementId _ ) As ElementId |
Visual C++ |
---|
public: ElementId^ Start( ElementId^ baseLevelId, ElementId^ topLevelId ) |
Parameters
- baseLevelId
- Type: Autodesk.Revit.DB..::..ElementId
The base level on which the stairs is to be placed.
- topLevelId
- Type: Autodesk.Revit.DB..::..ElementId
The top level where the stairs is to reach.
Return Value
ElementId of the new stairs.
Remarks
A new stairs will be created after this operation.
User will need to start a transaction to actually make changes to the stairs element.
StairsEditScope can only be started when there is no transaction active
Thus it does not work for commands running in automatic transaction mode.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | It is not a Level's id. -or- Top level should be higher than base level. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | StairsEditScope is not permitted to start at this moment for one of the following reasons: The document is in read-only state, or the document is currently modifiable, or there already is a stairs edit mode active in the document. |