Finds the analytical connection type by its name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2018

Syntax

C#
public static ElementId FindTypeByName(
	Document doc,
	string name
)
Visual Basic
Public Shared Function FindTypeByName ( _
	doc As Document, _
	name As String _
) As ElementId
Visual C++
public:
static ElementId^ FindTypeByName(
	Document^ doc, 
	String^ name
)

Parameters

doc
Type: Autodesk.Revit.DB..::..Document
The document where the analytical conneciton type is expected.
name
Type: System..::..String
The name of the expected analytical connection type.

Return Value

The element id of matched analytical connection type, otherwise invalidElementId.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException name is an empty string.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also