Used for the conceptual energy model.
The approximate percentage of the building exterior wall surfaces
which are covered by windows or other glazing.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public double PercentageGlazing { get; set; } |
Visual Basic |
---|
Public Property PercentageGlazing As Double Get Set |
Visual C++ |
---|
public: property double PercentageGlazing { double get (); void set (double value); } |
Remarks
This value is used to automatically model these glazed openings in
massing instances for the Conceptual Energy Analytical Model.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The percentage glazing value is not between 0.00 and 0.95. |