Prints a set of views with default view template and default print settings.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void Print( ViewSet views ) |
Visual Basic |
---|
Public Sub Print ( _ views As ViewSet _ ) |
Visual C++ |
---|
public: void Print( ViewSet^ views ) |
Parameters
- views
- Type: Autodesk.Revit.DB..::..ViewSet
The set of views which need to be printed.
Remarks
If one view in the set can not be printed successfully then an exception will be thrown.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when printing is not allowed in the current application mode. Or when at least one view from the view set is not a printable view. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the view set to be printed is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the view set contains a nullNothingnullptra null reference (Nothing in Visual Basic) element. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when at least one view from the view set could not be printed. |
Autodesk.Revit.Exceptions..::..OperationCanceledException | Thrown when print is cancelled by event handler. |