Returns all elements joined to given element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static ICollection<ElementId> GetJoinedElements( Document document, Element element ) |
Visual Basic |
---|
Public Shared Function GetJoinedElements ( _ document As Document, _ element As Element _ ) As ICollection(Of ElementId) |
Visual C++ |
---|
public: static ICollection<ElementId^>^ GetJoinedElements( Document^ document, Element^ element ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document containing the element.
- element
- Type: Autodesk.Revit.DB..::..Element
The element.
Return Value
The set of elements that are joined to the given element.
Remarks
This functionality is not available for family documents.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- The element element was not found in the given document. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |