Control the column extent in cases where the target is not a uniform height.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public enum ColumnAttachmentJustification |
Visual Basic |
---|
Public Enumeration ColumnAttachmentJustification |
Visual C++ |
---|
public enum class ColumnAttachmentJustification |
Members
Member name | Description |
---|---|
Minimum | Minimize the column extent, so that it comes in contact with the target but does not intersect. |
Midpoint | Extend the column until its midpoint contacts the target. |
Maximum | Extend the column until it is completely covered by the target, intersecting it if necessary. |
Tangent | For slanted columns only. Extend the column until its driving curve contacts the target, then cut the column with a plane tangent to the target at that contact point. |