Sets the out of plane hook rotation angle at the specified end.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2021

Syntax

C#
public void SetHookRotationAngle(
	double hookRotationAngle,
	int iEnd
)
Visual Basic
Public Sub SetHookRotationAngle ( _
	hookRotationAngle As Double, _
	iEnd As Integer _
)
Visual C++
public:
void SetHookRotationAngle(
	double hookRotationAngle, 
	int iEnd
)

Parameters

hookRotationAngle
Type: System..::..Double
The out of plane hook rotation angle at the specified end.
iEnd
Type: System..::..Int32
0 for the start , 1 for the end.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException iEnd must be 0 or 1.
Autodesk.Revit.Exceptions..::..DisabledDisciplineException None of the following disciplines is enabled: Structural.

See Also