Registers and returns the created Schema object.
Namespace: Autodesk.Revit.DB.ExtensibleStorageAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2012
Syntax
Visual Basic |
---|
Public Function Finish As Schema |
Visual C++ |
---|
public:
Schema^ Finish() |
Return Value
The newly created Schema.
Exceptions
Exception | Condition |
---|
Autodesk.Revit.Exceptions..::..InvalidOperationException |
The SchemaBuilder has already finished building the Schema.
-or-
A different Schema with a matching identity already exists.
-or-
Two fields with the same name are detected.
-or-
At least one field has invalid units.
-or-
SchemaName is not set.
-or-
VendorId is not set for a restricted access level.
-or-
ApplicationGUID is not set for an application access level.
-or-
More than 256 fields were added to the schema.
|
See Also