Rotates an element about the given axis and angle.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2012
Syntax
C# |
---|
public static void RotateElement(
Document document,
ElementId elementToRotate,
Line axis,
double angle
) |
Visual Basic |
---|
Public Shared Sub RotateElement ( _
document As Document, _
elementToRotate As ElementId, _
axis As Line, _
angle As Double _
) |
Visual C++ |
---|
public:
static void RotateElement(
Document^ document,
ElementId^ elementToRotate,
Line^ axis,
double angle
) |
Examples
CopyC#
public void RotateColumn(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
XYZ point1 = new XYZ(10, 20, 0);
XYZ point2 = new XYZ(10, 20, 30);
Line axis = Line.CreateBound(point1, point2);
ElementTransformUtils.RotateElement(document, element.Id, axis, Math.PI / 3.0);
}
CopyVB.NET
Public Sub RotateColumn(document As Autodesk.Revit.DB.Document, element As Autodesk.Revit.DB.Element)
Dim point1 As New XYZ(10, 20, 0)
Dim point2 As New XYZ(10, 20, 30)
Dim axis As Line = Line.CreateBound(point1, point2)
ElementTransformUtils.RotateElement(document, element.Id, axis, Math.PI / 3.0)
End Sub
Exceptions
See Also