Inserts a new MEPSize into the cable tray sizes.
For cable tray, the nominal diameter of MEPSize is used .
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public void AddSize( MEPSize sizeInfo ) |
Visual Basic |
---|
Public Sub AddSize ( _ sizeInfo As MEPSize _ ) |
Visual C++ |
---|
public: void AddSize( MEPSize^ sizeInfo ) |
Parameters
- sizeInfo
- Type: Autodesk.Revit.DB..::..MEPSize
The new MEPSize to be added.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | There is already the same size in the size set. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The function is called during iterating the size set. |