Enum class indicating kinds of paths which ExternalFileReferenceType.Material
references can have.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Since: 2012
Syntax
C# |
---|
public enum MaterialPropertyPathType |
Visual Basic |
---|
Public Enumeration MaterialPropertyPathType |
Visual C++ |
---|
public enum class MaterialPropertyPathType |
Members
Member name | Description |
---|---|
General | General image, for various material types |
Transparency | Transparency image, for generic materials |
Cutouts | Cutouts image, for generic or metal materials |
Bump | Bump pattern, for generic materials |
FinishBumps | Finish bumps, pattern for various material types |
ReliefPattern | Relief pattern, for various material types |
Weathering | Weathering image, for concrete materials |