A vector can be hook normal if for a bar specified by index, the bar direction is not parallel with the vector.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2018
Syntax
C# |
---|
public bool CanBeHookNormal(
int barIndex,
int end,
XYZ normal
) |
Visual Basic |
---|
Public Function CanBeHookNormal ( _
barIndex As Integer, _
end As Integer, _
normal As XYZ _
) As Boolean |
Visual C++ |
---|
public:
bool CanBeHookNormal(
int barIndex,
int end,
XYZ^ normal
) |
Parameters
- barIndex
- Type: System..::..Int32
The index of bar for which it will try to see if hook normal is applicable.
- end
- Type: System..::..Int32
The end of bar. Should be 0 for start, 1 for end.
- normal
- Type: Autodesk.Revit.DB..::..XYZ
The hook plane normal that will be tested.
Exceptions
See Also