Provides access to the Lighting Device in Autodesk Revit MEP.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public class LightingDevice : MEPModel
Visual Basic
Public Class LightingDevice _
	Inherits MEPModel
Visual C++
public ref class LightingDevice : public MEPModel

Remarks

The Lighting Device object can only be queried in Autodesk Revit MEP.

Inheritance Hierarchy

System..::..Object
  Autodesk.Revit.DB..::..APIObject
    Autodesk.Revit.DB..::..MEPModel
      Autodesk.Revit.DB.Electrical..::..LightingDevice

See Also