For ShapeDriven Rebar: returns true, if the Rebar element's external constraints are available for editing using the RebarConstraintsManager class. Examples of where this method would return false are: Rebar in Groups (which do not have constraints), or legacy, sketch-based Rebar elements created before the introduction of RebarShape families in version 2009.
For FreeForm rebar: constraints can be edited if there is a valid external server Guid assigned to that Rebar
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool ConstraintsCanBeEdited() |
Visual Basic |
---|
Public Function ConstraintsCanBeEdited As Boolean |
Visual C++ |
---|
public: bool ConstraintsCanBeEdited() |