Gets the number system reference corresponding to the given reference options.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public Reference GetNumberSystemReference( StairsNumberSystemReferenceOption referenceOption ) |
Visual Basic |
---|
Public Function GetNumberSystemReference ( _ referenceOption As StairsNumberSystemReferenceOption _ ) As Reference |
Visual C++ |
---|
public: Reference^ GetNumberSystemReference( StairsNumberSystemReferenceOption referenceOption ) |
Parameters
- referenceOption
- Type: Autodesk.Revit.DB.Architecture..::..StairsNumberSystemReferenceOption
The reference option.
Return Value
The reference.
Remarks
The return value of this function is suitable for use in NumberSystem.Create()
to associate a NumberSystem with the location on the StairsRun.
Don't try to get geometry curve from the reference.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |