Replaces a sorting/grouping field.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void SetSortGroupField( int index, ScheduleSortGroupField sortGroupField ) |
Visual Basic |
---|
Public Sub SetSortGroupField ( _ index As Integer, _ sortGroupField As ScheduleSortGroupField _ ) |
Visual C++ |
---|
public: void SetSortGroupField( int index, ScheduleSortGroupField^ sortGroupField ) |
Parameters
- index
- Type: System..::..Int32
The index of the sorting/grouping field to replace.
- sortGroupField
- Type: Autodesk.Revit.DB..::..ScheduleSortGroupField
The new sorting/grouping field.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field cannot be used for sorting/grouping. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | index is not a valid sorting/grouping field index. |