Gets or sets the text displayed on the item.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public virtual string ItemText { get; set; } |
Visual Basic |
---|
Public Overridable Property ItemText As String Get Set |
Visual C++ |
---|
public: virtual property String^ ItemText { String^ get (); void set (String^ value); } |
Remarks
The text can be changed at run time. nullNothingnullptra null reference (Nothing in Visual Basic) or empty string is not allowed.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when setting the text to empty or to the string contains "%". |
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when setting the text to nullNothingnullptra null reference (Nothing in Visual Basic). |