The operating schedule of the building used for conceptual model energy calculations.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public gbXMLBuildingOperatingSchedule BuildingOperatingSchedule { get; set; } |
Visual Basic |
---|
Public Property BuildingOperatingSchedule As gbXMLBuildingOperatingSchedule Get Set |
Visual C++ |
---|
public: property gbXMLBuildingOperatingSchedule BuildingOperatingSchedule { gbXMLBuildingOperatingSchedule get (); void set (gbXMLBuildingOperatingSchedule value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The building operating schedule does not fall within an appropriate range. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |