Gets the crop boundaries that are curently active.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public IList<CurveLoop> GetCropShape() |
Visual Basic |
---|
Public Function GetCropShape As IList(Of CurveLoop) |
Visual C++ |
---|
public: IList<CurveLoop^>^ GetCropShape() |
Return Value
The crop boundaries.
Remarks
This method returns a representation of the boundaries of the currently active crop for the associated view.
If the view crop has a non-rectangular shape, the method returns that shape.
Otherwise, if the view crop has been split, the method returns the multiple rectangular boundaries visible in the crop -
note that this does not reflect any offsets that may have been applied to the boundary regions.
If the crop is not split, this returns a single rectangle representing the crop.
All coordinates are in the coordinate frame of the view.