Constructs an instance of FilterIntegerRule.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2011
Syntax
Parameters
- valueProvider
- Type: Autodesk.Revit.DB..::..FilterableValueProvider
A pointer to a "value provider" object that will extract values from a Revit document.
- evaluator
- Type: Autodesk.Revit.DB..::..FilterNumericRuleEvaluator
A pointer to the filter rule evaluator object that implements the desired test.
The built-in evaluators implement commonly used tests such as less-than, greater-than
less-than-or-equal-to, equal, etc.
- ruleValue
- Type: System..::..Int32
The user-supplied value against which values from a Revit document will be tested.
Exceptions
See Also