Represents an extruded profile swept along a driving curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public class SweptProfile : IDisposable |
Visual Basic |
---|
Public Class SweptProfile _ Implements IDisposable |
Visual C++ |
---|
public ref class SweptProfile : IDisposable |
Remarks
Elements such as beams may be formed from a profile that has been swept
along a curve. This class represents such a form and is used to access the
cross section and the underlying curve that make up the Element.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..SweptProfile
Autodesk.Revit.DB..::..SweptProfile