Indicates if Analytical Model has Rigid Links with specified element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public bool HasRigidLinksWith( ElementId neighborId ) |
Visual Basic |
---|
Public Function HasRigidLinksWith ( _ neighborId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: bool HasRigidLinksWith( ElementId^ neighborId ) |
Parameters
- neighborId
- Type: Autodesk.Revit.DB..::..ElementId
neighboring Element, to which Rigid Links may exist.
Return Value
true if Rigid Links exist, false otherwise.
Remarks
This is bidirectional, so this can be used to see if Rigid Links exist from Column to Beam.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |