Add a profile into the form, by a specified edge/param.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public int AddProfile(
Reference edgeReference,
double param
) |
Visual Basic |
---|
Public Function AddProfile ( _
edgeReference As Reference, _
param As Double _
) As Integer |
Visual C++ |
---|
public:
int AddProfile(
Reference^ edgeReference,
double param
) |
Parameters
- edgeReference
- Type: Autodesk.Revit.DB..::..Reference
The geometry reference of edge.
- param
- Type: System..::..Double
The param on edge to specify the location.
Return Value
Index of newly created profile.
See Also