Constructs a new instance of a filter to match elements by category, with the option to match all elements which are of the given category.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2011
Syntax
C# |
---|
public ElementCategoryFilter(
ElementId categoryId,
bool inverted
) |
Visual Basic |
---|
Public Sub New ( _
categoryId As ElementId, _
inverted As Boolean _
) |
Visual C++ |
---|
public:
ElementCategoryFilter(
ElementId^ categoryId,
bool inverted
) |
Parameters
- categoryId
- Type: Autodesk.Revit.DB..::..ElementId
The category id to match.
- inverted
- Type: System..::..Boolean
True if the filter should match all elements which are not of the given category.
Exceptions
See Also