Creates an object that can be passed to View.SetBackground method
to set the background of the Gradient type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static ViewDisplayBackground CreateGradient( Color skyColor, Color horizonColor, Color groundColor ) |
Visual Basic |
---|
Public Shared Function CreateGradient ( _ skyColor As Color, _ horizonColor As Color, _ groundColor As Color _ ) As ViewDisplayBackground |
Visual C++ |
---|
public: static ViewDisplayBackground^ CreateGradient( Color^ skyColor, Color^ horizonColor, Color^ groundColor ) |
Parameters
- skyColor
- Type: Autodesk.Revit.DB..::..Color
The top of the sky gradient if the sky is visible.
- horizonColor
- Type: Autodesk.Revit.DB..::..Color
The bottom or the sky gradient if the sky is visible, or the top of the ground gradient otherwise.
- groundColor
- Type: Autodesk.Revit.DB..::..Color
The ground color if the sky is visible (ground shown in uniform color), or the bottom of the ground gradient if the sky is not visible.
Return Value
New background object to pass to View.SetBackground.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |