Populates analysis results data (or replaces the existing data) in the existing primitive identified by the unique index
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2012
Syntax
Visual Basic |
---|
Public Sub UpdateSpatialFieldPrimitive ( _
idx As Integer, _
fieldDomainPoints As FieldDomainPoints, _
fieldValues As FieldValues, _
resultIndex As Integer _
) |
Visual C++ |
---|
public:
void UpdateSpatialFieldPrimitive(
int idx,
FieldDomainPoints^ fieldDomainPoints,
FieldValues^ fieldValues,
int resultIndex
) |
Parameters
- idx
- Type: System..::..Int32
Unique index identifying the primitive
- fieldDomainPoints
- Type: Autodesk.Revit.DB.Analysis..::..FieldDomainPoints
Set of domain points.
If the new set of domain points is supplied, all previously supplied domain points and field values for all results are removed from the primitive.
If %fieldDomainPoints% is nullNothingnullptra null reference (Nothing in Visual Basic) only fieldValues are updated
- fieldValues
- Type: Autodesk.Revit.DB.Analysis..::..FieldValues
Set of data values.
Number of values in fieldValues must coincide with the number of points in fieldDomainPoints
- resultIndex
- Type: System..::..Int32
Unique index identifying the result schema
Exceptions
See Also