Constructs a new instance of an SelectableInViewFilter, with the option to pass all non-selectable elements.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2015

Syntax

C#
public SelectableInViewFilter(
	Document document,
	ElementId viewId,
	bool inverted
)
Visual Basic
Public Sub New ( _
	document As Document, _
	viewId As ElementId, _
	inverted As Boolean _
)
Visual C++
public:
SelectableInViewFilter(
	Document^ document, 
	ElementId^ viewId, 
	bool inverted
)

Parameters

document
Type: Autodesk.Revit.DB..::..Document
The document that owns the view.
viewId
Type: Autodesk.Revit.DB..::..ElementId
The view id.
inverted
Type: System..::..Boolean
True if the filter should match all elements not selectable in the given view.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException viewId is not a view. -or- viewId is not valid for element iteration, because it has no way of representing drawn elements. Many view templates will fail this check.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also