Used for both the detailed and conceptual energy model
Construction class of building as defined by:
loose, medium, tight, or none.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public HVACLoadConstructionClass BuildingConstructionClass { get; set; } |
Visual Basic |
---|
Public Property BuildingConstructionClass As HVACLoadConstructionClass Get Set |
Visual C++ |
---|
public: property HVACLoadConstructionClass BuildingConstructionClass { HVACLoadConstructionClass get (); void set (HVACLoadConstructionClass value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When setting this property: The building construction class does not fall within an appropriate range. |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |