Determines if a point lies within the volume of the Space.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public bool IsPointInSpace( XYZ point ) |
Visual Basic |
---|
Public Function IsPointInSpace ( _ point As XYZ _ ) As Boolean |
Visual C++ |
---|
public: bool IsPointInSpace( XYZ^ point ) |
Parameters
- point
- Type: Autodesk.Revit.DB..::..XYZ
Point to be checked.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the point is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | The coordinates of the point is not a number. |