Provides access to value as a string with unit in the given family parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public string AsValueString( FamilyParameter familyParameter ) |
Visual Basic |
---|
Public Function AsValueString ( _ familyParameter As FamilyParameter _ ) As String |
Visual C++ |
---|
public: String^ AsValueString( FamilyParameter^ familyParameter ) |
Parameters
- familyParameter
- Type: Autodesk.Revit.DB..::..FamilyParameter
Return Value
The string that represents the parameter value with unit.
Remarks
The method only applies to parameters of value types. If the parameter has no value or does not contain a numeric value,
the method returns nullNothingnullptra null reference (Nothing in Visual Basic).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"familyParameter"-is invalid. |