Unload the specified fabrication item files from the project.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2019
Syntax
C# |
---|
public void UnloadItemFiles( IList<FabricationItemFile> itemFiles ) |
Visual Basic |
---|
Public Sub UnloadItemFiles ( _ itemFiles As IList(Of FabricationItemFile) _ ) |
Visual C++ |
---|
public: void UnloadItemFiles( IList<FabricationItemFile^>^ itemFiles ) |
Parameters
- itemFiles
- Type: System.Collections.Generic..::..IList<(Of <(<'FabricationItemFile>)>)>
The fabrication item files to unload.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Fabrication item files can not be unloaded if they are currently in use. -or- Some fabrication item files have not been loaded. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The current fabrication configuration is not connected and updated to source configuration. Reload and try again. |