Gets the identifier of the unit used to quantify values.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public ForgeTypeId GetUnitTypeId() |
Visual Basic |
---|
Public Function GetUnitTypeId As ForgeTypeId |
Visual C++ |
---|
public: ForgeTypeId^ GetUnitTypeId() |
Remarks
Most units, such as square feet or degrees, are formatted as decimal
decimal numbers. Other units may be displayed with specialized
formatting methods like "feet and fractional inches" or "degrees,
minutes and seconds".
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | UseDefault is true in this FormatOptions. |